Специалисты в области безопасности предупреждают, что безопасность Linux и Unix компьютеров ставит по угрозу эксплойт Samba, через который злоумышленник может получить контроль над системой. Эта уязвимость позволяла вирусам на подобии WannaCry завладеть компьютером. К счастью, команда разработки Samba отреагировала оперативно и уже выпустила патч, закрывающий данную дыру в безопасности.

Уязвимость для WannaCry «Одной строки кода» в Samba исправлена

Напомним, что Samba это бесплатная программа с лицензией GNU GPL, широко используемая на компьютерах Linux для обеспечения работы с файлами и службами Windows. И благодаря своей популярности Samba может поставить под удар сотни и даже тысячи компьютеров.

С ID CVE-2017-7494 уязвимость была описана как возможность удаленного выполнения кода из общедоступного ресурса. Как говорится в описании, этот недостаток позволял хакерам загружать и заставить smbd сервер выполнять необходимую библиотеку из общего ресурса.

Сотрудник Cyphort Ник Билогорский поведал, что хоть и активных эксплойтов в свободном доступе не осталось, урон для Samba может быть велик, сообщает TechTarget. Этот недостаток распространяется на Samba 3.5 и более новых версиях.

Это связано с тем, что уязвимость позволяет удаленно выполнять код и злоумышленник всегда может получить полный контроль над компьютером. Этот недостаток был известен и ранее, но лишь последние события показали, что он серьезнее чем ожидалось.

После волны возмущений, захлестнувшей всех пользователей, сравнение уязвимости Samba и WannaCry просто неизбежно. Эксперты подчеркнули, что как и в случае с WannaCry, недостаток можно использовать как канал для использования «кротовой норы» и быстрого ее расширения.

Следует отметить, что эксплойт, использующий дыру в Samba будет использовать баги в том же протоколе SMB, что используют NSA средства WannaCry.

Неделей ранее команда из 40 разработчиков Samba выпустила обновление для устранения опасности. Кроме того, если добавить в файл smb.conf «nt pipe support = no» и перезапустить службу, то угроза будет сведена к минимуму, сообщает Cisco в статье по безопасности.

Эта уязвимость (CVE-2017-7494), теперь переименована в #SambaCry

Уязвимыми версиями Samba являются:

  • Samba Version < 4.6.4
  • Samba Version < 4.5.10
  • Samba Version < 4.4.14

и различные дистрибутивы GNU / Linux, такие как Ubuntu (USN-3296-1: Samba уязвимость), что указывает на то, что версии не уязвимы:

  • Ubuntu 17.04: samba 2:4.5.8+dfsg-0ubuntu0.17.04.2
  • Ubuntu 16.10: samba 2:4.4.5+dfsg-2ubuntu5.6
  • Ubuntu 16.04 LTS: samba 2:4.3.11+dfsg-0ubuntu0.16.04.7
  • Ubuntu 14.04 LTS: samba 2:4.3.11+dfsg-0ubuntu0.14.04.8

Если у вас есть дистрибутив Ubuntu (или производные), вы можете проверить установленную версию с помощью следующей команды:

apt list | grep samba-common -

 проверить установленную версию UBUNTU

Если вы знакомы с framework Metasploit, и вы хотите поэксперементировать, чтобы испытать этот подвиг, то уже в PoC CVE-2017-7494, вы можете попробовать, чтобы проверить уязвимость на вашей тестовой OS GNU / Linux.

 

Для комментирования ищите сообщение с hashtag #sambacry здесь